re = /([\w]+|\"[\w\s]+\")/
str = '\'sdkflkds sdfsdf "slkdfjsldkjf sdfskdjhk" dgdlkfgdlkj dflkgjhdfkljh "dfgkjdhgkjdh dsfkjdksjfhsdkjf" dfglkdjfgl\''
# Print the match result
str.scan(re) do |match|
puts match.to_s
end