$re = '/(https?:\/\/)?(www.)?(youtube\.com|youtu\.be|youtube-nocookie\.com)\/(?:embed\/|v\/|watch\?v=|watch\?list=(.*)&v=|watch\?(.*[^&]&)v=)?((\w|-){11})(&list=(\w+)&?)?/ims';
$str = 'https://www.youtube.com/watch?t=30&v=nt4fMMCNdRk
https://www.youtube.com/watch?v=-RWl24TUW6g
https://youtu.be/O5jUi3kBins
https://youtu.be/O5jUi3kBins?t=16s';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);