// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?ims)(https?:\/\/)?(www.)?(youtube\.com|youtu\.be|youtube-nocookie\.com)\/(?:embed\/|v\/|watch\?v=|watch\?list=(.*)&v=|watch\?(.*[^&]&)v=)?((\w|-){11})(&list=(\w+)&?)?").unwrap();
let string = "https://www.youtube.com/watch?t=30&v=nt4fMMCNdRk
https://www.youtube.com/watch?v=-RWl24TUW6g
https://youtu.be/O5jUi3kBins
https://youtu.be/O5jUi3kBins?t=16s";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}