$re = '/\~TARIFA:\~([\d\/]+)\~/';
$str = '~TARIFA:08/06/2016~';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);