#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^[a-zA-Z0-9\/_-]+(?:\.[a-zA-Z0-9]+)*$"
Local $sString = "testing:;/asdasd/asdasd" & @CRLF & _
"testing/testing/hello" & @CRLF & _
"testing/asdasdasd/asdasdasd.mp4" & @CRLF & _
"testing/asdasdasd/asdasdasd-mp4" & @CRLF & _
"asd.mp4" & @CRLF & _
"asd"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")