using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^[a-zA-Z0-9\/_-]+(?:\.[a-zA-Z0-9]+)*$";
string input = @"testing:;/asdasd/asdasd
testing/testing/hello
testing/asdasdasd/asdasdasd.mp4
testing/asdasdasd/asdasdasd-mp4
asd.mp4
asd";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}