package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^[a-zA-Z0-9\/_-]+(?:\.[a-zA-Z0-9]+)*$`)
var str = `testing:;/asdasd/asdasd
testing/testing/hello
testing/asdasdasd/asdasdasd.mp4
testing/asdasdasd/asdasdasd-mp4
asd.mp4
asd`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}