package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)\p{Zs}`)
var str = `this sentence would be tested true for spaces
thisOneWouldTestFalse`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}