re = /\p{Zs}/m
str = 'this sentence would be tested true for spaces
thisOneWouldTestFalse'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end