$re = '/\p{Zs}/m';
$str = 'this sentence would be tested true for spaces
thisOneWouldTestFalse';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);