package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^(\d|[1-2]\d|3[01]|99)$`)
var str = `0
2
01
10
15
23
31
32
99
100
000`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}