package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`\p{L}+(?:\s+\p{L}+){0,2}`)
var str = `1. Stąck is great and awesome`
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}