$re = '/\p{L}+(?:\s+\p{L}+){0,2}/';
$str = '1. Stąck is great and awesome';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);