const regex = /\p{L}+(?:\s+\p{L}+){0,2}/;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\p{L}+(?:\\s+\\p{L}+){0,2}', '')
const str = `1. Stąck is great and awesome`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}