package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?im)(https?|ftp|file):\/\/|www\.|ftp\.|([\w\-_]+(?:(?:\.|\s*\[dot\]\s*[A-Z\-_]+)+))([A-Z\-\.,@?^=%&:\/~\+#]*[A-Z\-\@?^=%&\/~\+#]){2,6}?`)
var str = `Click w3.test.com/test
test 1.6 test
test 1.6test
Click www.testpage.com
Click2 no desktop.test.com
test https://stackoverflow.com/questions/60619430/cant-get-newest-data-from-dao-unless-restart-the-app
word word https://stackoverflow.com/questions/6038061/regular-expression-to-find-urls-within-a-string test`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}