import re
regex = re.compile(r"(https?|ftp|file):\/\/|www\.|ftp\.|([\w\-_]+(?:(?:\.|\s*\[dot\]\s*[A-Z\-_]+)+))([A-Z\-\.,@?^=%&:\/~\+#]*[A-Z\-\@?^=%&\/~\+#]){2,6}?", flags=re.IGNORECASE | re.MULTILINE)
test_str = ("Click w3.test.com/test\n"
"test 1.6 test\n"
"test 1.6test\n"
"Click www.testpage.com\n"
"Click2 no desktop.test.com\n"
"test https://stackoverflow.com/questions/60619430/cant-get-newest-data-from-dao-unless-restart-the-app\n"
"word word https://stackoverflow.com/questions/6038061/regular-expression-to-find-urls-within-a-string test")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")