import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(https?|ftp|file):\\/\\/|www\\.|ftp\\.|([\\w\\-_]+(?:(?:\\.|\\s*\\[dot\\]\\s*[A-Z\\-_]+)+))([A-Z\\-\\.,@?^=%&:\\/~\\+#]*[A-Z\\-\\@?^=%&\\/~\\+#]){2,6}?";
final String string = "Click w3.test.com/test\n"
+ "test 1.6 test\n"
+ "test 1.6test\n"
+ "Click www.testpage.com\n"
+ "Click2 no desktop.test.com\n"
+ "test https://stackoverflow.com/questions/60619430/cant-get-newest-data-from-dao-unless-restart-the-app\n"
+ "word word https://stackoverflow.com/questions/6038061/regular-expression-to-find-urls-within-a-string test";
final Pattern pattern = Pattern.compile(regex, Pattern.CASE_INSENSITIVE | Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}