import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(-|\\s*|\\/\\/|\\/\\*|<!--|\\*|[*[0-9.]*)(\\s*)(TAG|d])(-*|:*|\\s*)(.*)";
final String string = "// TAG: this is bug!\n"
+ " // TAG: this is bug!\n"
+ "\\t // TAG: this is bug!\n"
+ "<!-- TAG: this is a hack!\n"
+ " <!-- TAG: this is a hack!\n"
+ "* TAG: need to fix this - TAG\n"
+ "- TAG: this is a todo!\n"
+ "/* TAG: this is a todo!\n"
+ "// TAG: warning or ignore\n"
+ "- [ ] this is an unfinished item\n"
+ "- [x] this item is finished\n"
+ "- [/] this item is finished\n"
+ "TAG: I said something\n"
+ "my comment - TAG\n\n"
+ "TAG attention!\n"
+ "?? question?\n"
+ "## Sample\n"
+ "[1.2d] | E2E QA & Debugging\n"
+ "[0.6d] | Release\n"
+ "~~ 14.9d\n"
+ "~~ 19d\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}