package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`("[^"]+"\s)?'.+`)
var str = `Working - This is a test 'This should be captured
Working - "this is a test" 'This should be captured
Not Working - "this is a test" 'This should be "captured"
Not Working - This is a test 'This should be "captured"
Working - "this is a test 'this should not capture'" 'this should capture
Working - "this isn't a test" 'this should capture`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}