re = /("[^"]+"\s)?'.+/
str = 'Working - This is a test \'This should be captured
Working - "this is a test" \'This should be captured
Not Working - "this is a test" \'This should be "captured"
Not Working - This is a test \'This should be "captured"
Working - "this is a test \'this should not capture\'" \'this should capture
Working - "this isn\'t a test" \'this should capture'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end