// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r#"("[^"]+"\s)?'.+"#).unwrap();
let string = "Working - This is a test 'This should be captured
Working - \"this is a test\" 'This should be captured
Not Working - \"this is a test\" 'This should be \"captured\"
Not Working - This is a test 'This should be \"captured\"
Working - \"this is a test 'this should not capture'\" 'this should capture
Working - \"this isn't a test\" 'this should capture";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}