#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^[^\d\n\r]*\d+(?:[,.]\d+)*([^\d\n\r]+)\d"
Local $sString = "testsfa13.4extractthis8488.9090testssffwwww" & @CRLF & _
"" & @CRLF & _
"ajfafs-sss133.6extractthis887878.222testtest522252.9thismore"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")