const regex = /^[^\d\n\r]*\d+(?:[,.]\d+)*([^\d\n\r]+)\d/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^[^\\d\\n\\r]*\\d+(?:[,.]\\d+)*([^\\d\\n\\r]+)\\d', 'gm')
const str = `testsfa13.4extractthis8488.9090testssffwwww
ajfafs-sss133.6extractthis887878.222testtest522252.9thismore`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}