const regex = new RegExp('(?<=(0)|(1)|(2))(?(1)([1379]))(?(2)(5|10))(?(3)([02468]))', 'gm')
const str = `01
15
22
08
13
29
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}