$re = '/(?<=(0)|(1)|(2))(?(1)([1379]))(?(2)(5|10))(?(3)([02468]))/m';
$str = '01
15
22
08
13
29
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);