re = /(?<=(0)|(1)|(2))(?(1)([1379]))(?(2)(5|10))(?(3)([02468]))/m
str = '01
15
22
08
13
29
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end