const regex = /[^\w.]+|\.(?=[^.]*\.)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('[^\\w.]+|\\.(?=[^.]*\\.)', 'gm')
const str = `daryaa-manmarziyan-(VideoStatus.Net).mp4`;
const subst = ``;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);