use strict;
my $str = 'daryaa-manmarziyan-(VideoStatus.Net).mp4';
my $regex = qr/[^\w.]+|\.(?=[^.]*\.)/mp;
my $subst = '';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";