#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(?:\s*([a-zA-Z()+ ]+?)[ =]*)([-+]?\d+\.?\d*)"
Local $sString = "Molecular weight = 43057.32 Residues = 391 " & @CRLF & _
"Average Residue Weight = 110.121 Charge = -10.0" & @CRLF & _
"Isoelectric Point = 4.8926" & @CRLF & _
"" & @CRLF & _
"Residue Number Mole% DayhoffStat" & @CRLF & _
"A = Ala 24 6.138 0.714 " & @CRLF & _
"B = Asx 0 0.000 0.000 " & @CRLF & _
"C = Cys 9 2.302 0.794 " & @CRLF & _
"" & @CRLF & _
"Property Residues Number Mole%" & @CRLF & _
"Tiny (A+C+G+S+T) 135 34.527" & @CRLF & _
"Small (A+B+C+D+G+N+P+S+T+V) 222 56.777" & @CRLF & _
"Aliphatic (A+I+L+V) 97 24.808"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")