# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"(?:\s*([a-zA-Z()+ ]+?)[ =]*)([-+]?\d+\.?\d*)"
test_str = ("Molecular weight = 43057.32 Residues = 391 \n"
"Average Residue Weight = 110.121 Charge = -10.0\n"
"Isoelectric Point = 4.8926\n\n"
"Residue Number Mole% DayhoffStat\n"
"A = Ala 24 6.138 0.714 \n"
"B = Asx 0 0.000 0.000 \n"
"C = Cys 9 2.302 0.794 \n\n"
"Property Residues Number Mole%\n"
"Tiny (A+C+G+S+T) 135 34.527\n"
"Small (A+B+C+D+G+N+P+S+T+V) 222 56.777\n"
"Aliphatic (A+I+L+V) 97 24.808")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.