const regex = /^(?(?=List\sParagraph\t\d+\)\s)List\sParagraph\t\d+\)\s)(?(?=Normal\t)Normal\t)(.*)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(?(?=List\\sParagraph\\t\\d+\\)\\s)List\\sParagraph\\t\\d+\\)\\s)(?(?=Normal\\t)Normal\\t)(.*)', 'gm')
const str = `1-Details on the requirement
List Paragraph 123) Details...
Normal
List Paragraph 124) 2-Comments
List Paragraph 125) Some Comments...
Normal
List Paragraph 126) 3-Justification
List Paragraph 127) Some justification
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}