$re = '/^(?(?=List\sParagraph\t\d+\)\s)List\sParagraph\t\d+\)\s)(?(?=Normal\t)Normal\t)(.*)/m';
$str = '1-Details on the requirement
List Paragraph 123) Details...
Normal
List Paragraph 124) 2-Comments
List Paragraph 125) Some Comments...
Normal
List Paragraph 126) 3-Justification
List Paragraph 127) Some justification
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);