import re
regex = re.compile(r"^(?(?=List\sParagraph\t\d+\)\s)List\sParagraph\t\d+\)\s)(?(?=Normal\t)Normal\t)(.*)", flags=re.MULTILINE)
test_str = ("1-Details on the requirement\n"
"List Paragraph 123) Details...\n"
"Normal \n"
"List Paragraph 124) 2-Comments\n"
"List Paragraph 125) Some Comments...\n"
"Normal \n"
"List Paragraph 126) 3-Justification\n"
"List Paragraph 127) Some justification\n\n\n\n")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")