using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^\W*(?:(?!name\b)\w+\W+)*?Jack.*";
string input = @"Who is Jack Brown?
My name is Jack Brown
Jack Brown is my name";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}