re = /^\W*(?:(?!name\b)\w+\W+)*?Jack.*/m
str = 'Who is Jack Brown?
My name is Jack Brown
Jack Brown is my name'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end