$re = '/^\W*(?:(?!name\b)\w+\W+)*?Jack.*/m';
$str = 'Who is Jack Brown?
My name is Jack Brown
Jack Brown is my name';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);