package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?mi).*wmic.*process.*call.*create.*|.*invoke-wmimethod.*(-class win32_process|-name create).*(-name create|-class win32_process).*`)
var str = `wmic process call create
wmic process call create “notepad.exe”
wmic /node:IP process call create “calc.exe”
wmic /node:10.146.215.157 process call create "notepad.exe"
invoke-wmimethod -Class win32_process -Name create -ArguementList "calc.exe" -ComputerName "tdiscwin-as-t1p"
Invoke-WmiMethod -Class win32_process -Name create -ArguementList "calc.exe" -ComputerName "tdiscwin-as-t1p"
Invoke-WmiMethod -Class Win32_Process -name Create -ArguementList 'notepad.exe' -ComputerName 192.168.72.134 - Credential 'WIN-B85AAA7ST4U\Administrator'
Invoke-WmiMethod -ComputerName Test -Class Win32_Process -Name Create -ArgumentList "Notepad.exe"
Invoke-WmiMethod -Name Create -Class Win32_Process -ArgumentList "Notepad.exe"`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}