import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = ".*wmic.*process.*call.*create.*|.*invoke-wmimethod.*(-class win32_process|-name create).*(-name create|-class win32_process).*";
final String string = "wmic process call create\n"
+ "wmic process call create “notepad.exe”\n"
+ "wmic /node:IP process call create “calc.exe”\n"
+ "wmic /node:10.146.215.157 process call create \"notepad.exe\"\n"
+ "invoke-wmimethod -Class win32_process -Name create -ArguementList \"calc.exe\" -ComputerName \"tdiscwin-as-t1p\"\n"
+ "Invoke-WmiMethod -Class win32_process -Name create -ArguementList \"calc.exe\" -ComputerName \"tdiscwin-as-t1p\"\n"
+ "Invoke-WmiMethod -Class Win32_Process -name Create -ArguementList 'notepad.exe' -ComputerName 192.168.72.134 - Credential 'WIN-B85AAA7ST4U\\Administrator'\n"
+ "Invoke-WmiMethod -ComputerName Test -Class Win32_Process -Name Create -ArgumentList \"Notepad.exe\"\n"
+ "Invoke-WmiMethod -Name Create -Class Win32_Process -ArgumentList \"Notepad.exe\"";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE | Pattern.CASE_INSENSITIVE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}