import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^\n"
+ "(?=.{2,}) # assert length of two or more?\n"
+ "(?:a(?=.*))*\n"
+ "(?:b(?=.*[^a].*))*\n"
+ "(?:c(?=.*[^a-b].*))*\n"
+ "(?:d(?=.*[^a-c].*))*\n"
+ "# add in the rest...\n"
+ "$";
final String string = "abbbcccd\n"
+ "baab\n"
+ "abc\n"
+ "abd\n"
+ "adb\n"
+ "ab\n"
+ "a\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE | Pattern.COMMENTS);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}