$re = '/^
(?=.{2,}) # assert length of two or more?
(?:a(?=.*))*
(?:b(?=.*[^a].*))*
(?:c(?=.*[^a-b].*))*
(?:d(?=.*[^a-c].*))*
# add in the rest...
$/mx';
$str = 'abbbcccd
baab
abc
abd
adb
ab
a
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);