// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?mx)^
(?=.{2,}) # assert length of two or more?
(?:a(?=.*))*
(?:b(?=.*[^a].*))*
(?:c(?=.*[^a-b].*))*
(?:d(?=.*[^a-c].*))*
# add in the rest...
$").unwrap();
let string = "abbbcccd
baab
abc
abd
adb
ab
a
";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}