const regex = /(?:^|[.!?]\s+)\w/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?:^|[.!?]\\s+)\\w', 'g')
const str = `this site and the internet are filled with answers to 'how to capitalize every word' but that isn't what I want to do. and I couldn't find any answers anywhere to this question? though it does seem like something that should have been answered well!
this site and the internet are filled with answers to 'how to capitalize every word' but that isn't what I want to do. and I couldn't find any answers anywhere to this question? though it does seem like something that should have been answered well!
this site and the internet are filled with answers to 'how to capitalize every word' but that isn't what I want to do.and I couldn't find any answers anywhere to this question? though it does seem like something that should have been answered well!`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}