use strict;
my $str = 'this site and the internet are filled with answers to \'how to capitalize every word\' but that isn\'t what I want to do. and I couldn\'t find any answers anywhere to this question? though it does seem like something that should have been answered well!
this site and the internet are filled with answers to \'how to capitalize every word\' but that isn\'t what I want to do. and I couldn\'t find any answers anywhere to this question? though it does seem like something that should have been answered well!
this site and the internet are filled with answers to \'how to capitalize every word\' but that isn\'t what I want to do.and I couldn\'t find any answers anywhere to this question? though it does seem like something that should have been answered well!';
my $regex = qr/(?:^|[.!?]\s+)\w/p;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}