re = /(?:^|[.!?]\s+)\w/
str = 'this site and the internet are filled with answers to \'how to capitalize every word\' but that isn\'t what I want to do. and I couldn\'t find any answers anywhere to this question? though it does seem like something that should have been answered well!
this site and the internet are filled with answers to \'how to capitalize every word\' but that isn\'t what I want to do. and I couldn\'t find any answers anywhere to this question? though it does seem like something that should have been answered well!
this site and the internet are filled with answers to \'how to capitalize every word\' but that isn\'t what I want to do.and I couldn\'t find any answers anywhere to this question? though it does seem like something that should have been answered well!'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end