#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(java\.lang\.NullPointerException[\s\S]*){2,}"
Local $sString = "2020-01-31 00:00:01 - Searching for account details" & @CRLF & _
"Error:" & @CRLF & _
"java.lang.NullPointerException" & @CRLF & _
"2020-01-31 00:00:30 - Searching for account details" & @CRLF & _
"Error:" & @CRLF & _
"java.lang.NullPointerException" & @CRLF & _
"2020-01-31 00:00:50 - Searching for account details" & @CRLF & _
"Error:" & @CRLF & _
"java.lang.NullPointerException"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")