re = /(java\.lang\.NullPointerException[\s\S]*){2,}/m
str = '2020-01-31 00:00:01 - Searching for account details
Error:
java.lang.NullPointerException
2020-01-31 00:00:30 - Searching for account details
Error:
java.lang.NullPointerException
2020-01-31 00:00:50 - Searching for account details
Error:
java.lang.NullPointerException'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end