package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(java\.lang\.NullPointerException[\s\S]*){2,}`)
var str = `2020-01-31 00:00:01 - Searching for account details
Error:
java.lang.NullPointerException
2020-01-31 00:00:30 - Searching for account details
Error:
java.lang.NullPointerException
2020-01-31 00:00:50 - Searching for account details
Error:
java.lang.NullPointerException`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}