#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?imu)[^\p{L}\d_]"
Local $sString = "फ्रांस"
Local $sSubst = ""
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)