const regex = /[^\p{L}\d_]/gimu;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('[^\\p{L}\\d_]', 'gimu')
const str = `फ्रांस`;
const subst = ``;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);