import re
regex = re.compile(r"[^\p{L}\d_]", flags=re.IGNORECASE | re.MULTILINE | re.UNICODE)
test_str = "फ्रांस"
subst = ""
result = regex.sub(subst, test_str)
if result:
print(result)